Fix: SSL_Error_Weak_Server_Ephemeral_Dh_Key – Appuals.com

Berichten zufolge stoßen mehrere Benutzer auf die SSL_Error_Weak_Server_ephemeral_DH_key Fehler beim Versuch, auf bestimmte Websites zuzugreifen. Das Problem scheint spezifisch für den Firefox-Browser zu sein, es wird jedoch nur bei mehreren verschiedenen Builds gemeldet.

SSL_Error_Weak_Server_ephemeral_Dh_key

Was verursacht den Fehler SSL_Error_Weak_Server_ephemeral_Dh_key?

Dieser Fehler wird allgemein als Diffie Hellman-Fehler bezeichnet und ist ein bekanntes Fehler- und Kompatibilitätsproblem. Es tritt auf, wenn Firefox einige Chiffren aktiv blockiert und von UCCX keine Alternative angeboten wird. Es kann auch vorkommen, dass die angebotene Alternative von Firefox nicht akzeptiert wird.

Grundsätzlich heißt es in der Fehlermeldung, dass die Site, die Sie besuchen möchten, ihr Sicherheitszertifikat auf den neuesten Stand bringen muss, um nicht für Logjam-Angriffe anfällig zu werden.

Auch wenn das Problem nicht auf Ihrer Seite liegt, möchten Sie auf diese bestimmte Site zugreifen und Sicherheitswarnungen ignorieren. Sie können dies ganz einfach tun (mehr dazu weiter unten).

Schauen wir uns zunächst einige Szenarien an, die diese bestimmte Fehlermeldung auslösen. Wir haben diese spezielle Fehlermeldung untersucht, indem wir uns verschiedene Benutzerberichte und die Methoden angesehen haben, mit denen das Problem behoben wurde. Basierend auf dem, was wir gesammelt haben, gibt es mehrere gemeinsame Faktoren, die zur Erscheinung dieses Problems führen werden:

  • Firefox-Fehler – Es gibt einen bekannten Fehler, seit Firefox 31 diese bestimmte Fehlermeldung auslöst. Das Problem wurde seitdem behoben, aber bei älteren Builds tritt es möglicherweise immer noch auf.
  • Eine Änderung des Firefox-Verhaltens – Mit Firefox 33 wurde der Browser auf ein strengeres libPKIS umgestellt. Sie können diese Bibliothek nicht mehr deaktivieren und auf den vorherigen NSS-Code zurückgreifen. Dies ist der Grund, warum Sie das Problem umgehen können, indem Sie auf „Ich verstehe die Risiken“ klicken.
  • Die von der Website verwendete Schlüsselgröße ist nicht mit Firefox kompatibel – Ein weiterer Faktor, der das Problem auslösen kann, ist die Schlüsselgröße, die von der Website verwendet wird, die Sie besuchen möchten. Ab Firefox 33 unterstützt der Browser keine Schlüsselgrößen mehr als 1024 Bit.

Wenn Sie derzeit Probleme haben, diese bestimmte Fehlermeldung zu beheben, finden Sie in diesem Artikel eine Liste der überprüften Schritte zur Fehlerbehebung. Im Folgenden finden Sie verschiedene Methoden, mit denen andere Benutzer in einer ähnlichen Situation das Problem behoben haben.

Um die besten Ergebnisse zu erzielen, befolgen Sie die folgenden Methoden in der angegebenen Reihenfolge, bis Sie einen Fix finden, mit dem Sie das Problem in Ihrem speziellen Szenario effektiv umgehen können.

Methode 1: Aktualisieren Sie Firefox auf die neueste Version

Stellen Sie zunächst sicher, dass Ihr Firefox auf die neueste Version aktualisiert wurde. Wenn Sie sicherstellen, dass Sie die neueste verfügbare Version ausführen, wird die Möglichkeit ausgeschlossen, dass dieser Fehler aufgrund eines Fehlers auftritt.

Mehrere betroffene Benutzer haben gemeldet, dass das Problem für sie behoben wurde, nachdem sie den Browser auf den neuesten Build aktualisiert haben. Hier ist eine Kurzanleitung dazu:

  1. Öffnen Sie Firefox und klicken Sie auf die Aktionsschaltfläche in der oberen rechten Ecke. Dann geh zu Hilfe und klicken Sie auf Über Firefox.
    Zugriff auf das Hilfemenü von Firefox
  2. In dem Über Mozilla Firefox Fenster, klicken Sie auf Starten Sie neu, um Firefox zu aktualisieren und warten Sie, bis der Vorgang abgeschlossen ist. Wenn Sie vom Firefox Updater dazu aufgefordert werden UAC (Benutzerkontensteuerung)Wählen Sie Ja, um Administratorrechte zu erteilen.
    Aktualisieren von Firefox auf die neueste Version
  3. Besuchen Sie nach dem Neustart von Firefox dieselbe Website, auf der Sie zuvor Probleme hatten, und prüfen Sie, ob immer noch dieselbe Fehlermeldung angezeigt wird.

Wenn Sie das noch sehen SSL_Error_Weak_Server_ephemeral_DH_key Fehler, fahren Sie mit der nächsten Methode fort.

Methode 2: Ersetzen des unsicheren Fallback-Hosts

Die meisten Benutzer, die auf die stoßen SSL_Error_Weak_Server_ephemeral_DH_key Fehler haben es geschafft, das Problem zu beheben, indem Sie das versteckte Firefox-Konfigurationsmenü aufrufen und das einstellen security.tls.insecure_fallback_hosts Zeichenfolge für die Domäne, in der die Fehlermeldung angezeigt wird.

Hier ist eine Kurzanleitung dazu:

  1. Öffnen Sie Firefox und geben Sie „about: config”In der Navigationsleiste und drücken Sie Eingeben.
    Zugriff auf das Konfigurationsmenü von Firefox
  2. Wenn der “Dies könnte Ihre Garantie ungültig machen!” Bildschirm erscheint, klicken Sie auf Ich akzeptiere das Risiko!.
    Rufen Sie das Konfigurationsmenü auf, indem Sie bestätigen, dass Sie die Risiken akzeptieren
  3. Wenn Sie im Konfigurationsmenü angekommen sind, fügen Sie „security.tls.insecure_fallback_hosts”In der Suchleiste und drücken Sie Eingeben um die Zeichenfolge zu finden, die wir ändern müssen.
    Suchen nach der Zeichenfolge security.tls.insecure_fallback_hosts
  4. Wenn Sie es gefunden haben, doppelklicken Sie darauf, um das zugehörige Dialogfeld zu öffnen. Geben Sie im Feld Wert für Zeichenfolge eingeben die Domäne ein, mit der die Fehlermeldung angezeigt wird, und klicken Sie auf In Ordnung.
  5. Starten Sie Firefox neu und prüfen Sie, ob immer noch dieselbe Fehlermeldung angezeigt wird.

Wenn immer noch dieselbe Fehlermeldung angezeigt wird, fahren Sie mit der folgenden Methode fort.

Methode 3: Aktivieren der SSL3-Einstellungen

Mehrere Benutzer konnten das Problem beheben Sichere Verbindung fehlgeschlagen (ssl_error_weak_server_ephemeral_dh_key) Fehler durch Aktivieren einiger Einstellungen im Menü about: config.

Dieser spezielle Fix war Berichten zufolge für viele Benutzer wirksam, die aufgrund dieser speziellen Fehlermeldung nicht auf ihren Router zugreifen konnten. Hier ist eine Kurzanleitung zum Aktivieren der SSL3-Einstellungen:

  1. Öffnen Sie Firefox und geben Sie ein about: config in der Navigationsleiste und drücken Sie Eingeben Öffnen Sie das versteckte Konfigurationsmenü.
    Zugriff auf das Konfigurationsmenü von Firefox
  2. Wenn der “Dies könnte Ihre Garantie ungültig machen!” Bildschirm erscheint, klicken Sie auf Ich akzeptiere das Risiko!.

    Bestätigen des Warnzeichens
  3. Verwenden Sie im Konfigurationsmenü die Suchfunktion, um den folgenden booleschen Eintrag zu finden:
    security.ssl3.dhe_rsa_aes_128_sha
  4. Wenn der Wert dieses Booleschen Werts nicht auf gesetzt ist FalschDoppelklicken Sie darauf, um es selbst zu tun.
    Stellen Sie sicher, dass der erste Boolesche Wert auf True gesetzt ist
  5. Verwenden Sie dieselbe Suchfunktion, um nach dem zweiten booleschen Eintrag zu suchen:
    security.ssl3.dhe_rsa_aes_256_sha
  6. Wenn der Wert wahr ist, doppelklicken Sie wie zuvor darauf, um ihn festzulegen Falsch.
    Setzen Sie den Booleschen Wert auf false
  7. Starten Sie Firefox nach Abschluss der beiden Änderungen neu und prüfen Sie, ob die Fehlermeldung beim nächsten Start behoben wurde.

Similar Posts

Leave a Reply

Your email address will not be published.