Notepad++-Plugins können unter Windows 10 nicht installiert werden

Einige Windows 10-Benutzer berichten, dass sie keine Plugins auf ihrer Notepad ++-Installation installieren können. Es gibt mehrere verschiedene Fehlermeldungen, die mit diesem Problem verbunden sind, aber die häufigste ist „Installationsfehler: Die Installation von Compare ist fehlgeschlagen.“

Notepad++-Plugins können nicht installiert werden

Nach eingehender Untersuchung dieses speziellen Problems stellt sich heraus, dass es mehrere verschiedene zugrunde liegende Ursachen gibt, die diese Art von Fehler mit auslösen können Notizblock++. Hier ist eine Liste potenzieller Täter, die dieses Problem verursachen könnten:

  • Fehlende Administratorrechte – Eine der häufigsten Situationen, die dieses Problem mit Notepad ++ verursachen, ist eine Situation, in der die Anwendung nicht über ausreichende Berechtigungen verfügt, um Änderungen an vorhandenen Dateien zuzulassen. Wie von vielen betroffenen Benutzern bestätigt wurde, können Sie dieses Problem beheben, indem Sie den Administratorzugriff auf den Launcher erzwingen.
  • Das Plugin kann nicht konventionell installiert werden – Wenn Sie versuchen, ein Plugin über ein extern verwaltetes Plugin zu installieren, schlägt dies wahrscheinlich fehl, weil es nicht mit Sideloading kompatibel ist. In diesem Fall können Sie versuchen, das Plugin über das Plugin-Manager-Modul in Notepad++ zu installieren.
  • Erforderliche Transport Layer Security ist deaktiviert – Denken Sie daran, dass, wenn dieser Fehler beim Versuch, ein Legacy-Plugin zu installieren, angezeigt wird, möglicherweise eine wichtige Sicherheitsfunktion der Transportschicht fehlt, die vom Plugin erforderlich ist. Um dieses Problem in diesem Fall zu beheben, müssen Sie die erforderliche TLS-Technologie im Menü Erweiterte Einstellungen der Internetoptionen aktivieren.
  • Veraltete Notepad++-Version – Wie sich herausstellt, können Sie dieses spezielle Problem auch in Situationen erwarten, in denen Sie eine stark veraltete Notepad++-Version verwenden, die nicht mit Windows 10 kompatibel ist. In diesem Fall sollten Sie das Problem durch die Installation beheben können die neueste Version von Notepad++.
  • Plugin Manager Plugin ist kaputt – Unter bestimmten Umständen können Sie davon ausgehen, dass dieses Problem aufgrund eines Problems mit der in Notepad++ enthaltenen Plugin-Manager-Funktion auftritt. In diesem Fall können Sie den Fehler vermeiden, indem Sie die Plugins, die Sie installieren möchten, seitlich laden.

Jetzt, da Sie jedes Szenario, das dieses spezielle Problem verursachen könnte, genau kennen, finden Sie hier eine Liste verifizierter Methoden, die andere betroffene Benutzer effektiv verwendet haben, um diesem Problem auf den Grund zu gehen:

Methode 1: Ausführen von Notepad ++ als Administrator

Wie sich herausstellt, ist eines der häufigsten Probleme, die diesen speziellen Fehlercode auslösen können, ein Fall, in dem die Notepad++-Anwendung nicht über ausreichende Berechtigungen verfügt, um die Installation neuer Plugins zu verwalten.

Wie in der offiziellen Dokumentation empfohlen, benötigt Notepad++ Administratorzugriff, um Aufgaben auszuführen, die das Ändern der ursprünglichen Installation umfassen (die Installation neuer Plugins fällt in diese Kategorie).

Beruht auf deiner UAC (Benutzerkontoeinstellungen) können Sie davon ausgehen, dass dieses Problem in Fällen auftritt, in denen die Notepad++-Anwendung keinen Administratorzugriff erhalten hat.

Wenn dieses Szenario zutrifft, befolgen Sie die folgenden Anweisungen, um das Betriebssystem zu zwingen, Notepad ++ mit Administratorzugriff zu öffnen, und ändern Sie zukünftige Starts der App so, dass sie mit Administratorzugriff geöffnet werden:

  1. Klicken Sie mit der rechten Maustaste auf die Notepad++-Verknüpfung, die Sie zum Starten des Spiels verwenden, und klicken Sie auf Als Administrator ausführen aus dem gerade erschienenen Kontextmenü.
    Ausführen von Notepad++ als Administrator
  2. Wenn Sie vom . dazu aufgefordert werden UAC (Benutzerkontensteuerung), klicken Ja Administratorzugriff zu gewähren.
  3. Sobald Sie sichergestellt haben, dass Sie geöffnet haben Notizblock++ Versuchen Sie mit Administratorzugriff erneut, die Plugins zu installieren, und prüfen Sie, ob das Problem jetzt behoben ist.

Falls du immer noch dasselbe siehst „Installationsfehler: Installation von Compare fehlgeschlagen.“, weiter unten zum nächsten möglichen Fix.

Methode 2: Installieren des Plugins über den Plugin-Manager

In den meisten Fällen tritt dieses spezielle Problem in Fällen auf, in denen Benutzer versuchen, Plugins manuell oder mithilfe eines externen Moduls zu installieren. Dies kann bei älteren Notepad++-Installationen zu Problemen führen, insbesondere bei Windows 10, wo die Sicherheitsprotokolle strenger sind.

Wenn Sie sich in diesem Szenario befinden, befolgen Sie die nachstehenden Anweisungen, um die Plugin Manager So installieren Sie das Notepad++-Plugin, das zuvor nicht installiert werden konnte:

Hinweis: Bei dieser Methode wird davon ausgegangen, dass Sie bereits die neueste Version von . verwenden Notizblock++ und Sie haben keine Restdateien, die den Vorgang stören könnten. Wenn dies nicht der Fall ist, gehen Sie zu Methode 3 und befolgen Sie diese zuerst, bevor Sie die folgenden Anweisungen befolgen.

  1. Öffne die Notizblock++ Anwendung und verwenden Sie das Menüband oben, um auf zu klicken Plugins, dann klick auf Plugin-Administrator aus dem gerade erschienenen Kontextmenü.
    Zugriff auf das Plugins-Menü von Notepad++
  2. Sobald du in der bist Plugin-Administrator Menü, wählen Sie die Verfügbar Menü aus der Multifunktionsleiste oben und verwenden Sie dann die Suchfunktion, um das Plugin zu finden, das Sie installieren möchten.
    Installieren von Plugins über den Plugin-Manager
  3. Sobald Sie jedes Plugin, das Sie installieren möchten, erfolgreich identifiziert haben, aktivieren Sie das jeweilige Kontrollkästchen und klicken Sie dann auf Installieren Schaltfläche, um die Installation zu starten.
  4. Klicken Sie in der Bestätigungsaufforderung auf Ja und warte auf Notizblock++ neu starten und das Plugin installieren.
    Installieren des neuen Plugins für Notepad++
  5. Bei Aufforderung durch den UAC (Benutzerkontensteuerung), klicken Ja um Administratorzugriff zu gewähren, und warten Sie dann, bis der Vorgang abgeschlossen ist.

Falls dieser Versuch, Plugins zu installieren, zum selben Ergebnis führt „Installationsfehler: Installation von Compare fehlgeschlagen.“, weiter unten zum nächsten möglichen Fix.

Methode 3: Aktivieren von TLS 1.0, TLS 1.1 und TLS 1.2

Wenn dieses Problem auftritt, während Sie versuchen, den Plugin-Manager von Notepad++ zum Installieren von Plugins zu verwenden, ist es auch möglich, dass der Vorgang fehlschlägt, weil a Transport Layer Security (TLS) Technologie, die auf Ihrem Computer nicht aktiv ist, aber vom Notepad++-Plugin benötigt wird.

In diesem Fall sollten Sie das Problem beheben können, indem Sie auf das Internet Optionen Bildschirm und aktivieren Sie TLS 1.0, TLS 1.1 und TLS 1.2 über das Erweiterte Einstellungen Speisekarte.

Wenn dieses Szenario mit Ihrer aktuellen Situation kompatibel ist, befolgen Sie die folgenden Anweisungen, um sicherzustellen, dass Sie jede Transportschichtsicherheit aktivieren, die dieses Problem verursachen könnte:

  1. Drücken Sie Windows-Taste + R sich öffnen Lauf Dialogbox. Geben Sie als Nächstes ein ‘Steuerung’ in das Textfeld ein und drücken Sie dann die Eingabetaste, um den Klassiker zu öffnen Schalttafel Schnittstelle. Wenn Sie vom . dazu aufgefordert werden UAC (Benutzerkontensteuerung), klicken Ja Administratorzugriff zu gewähren.
    Zugreifen auf das Menü der klassischen Systemsteuerung
  2. Sobald du in der bist klassische Systemsteuerung Benutzeroberfläche verwenden Sie die Suchfunktion (oberer rechter Bildschirmbereich), um nach ‘Internet Optionen’. Klicken Sie in der Ergebnisliste auf Internet Optionen.
    Auf das Menü Internetoptionen zugreifen
  3. Innerhalb der Internet Optionen Menü, klicken Sie auf das Fortgeschritten Menü aus dem horizontalen Menü oben. Scrollen Sie im Inneren durch die Liste der die Einstellungen bis du die erreichst Sicherheit Kategorie.
  4. Innerhalb der Sicherheit Registerkarte, stellen Sie sicher, dass die Kästchen mit TLS 1.0 verwenden, TLS 1.1 verwenden, und Verwenden Sie TLS 1.2 sind alle aktiviert, bevor Sie auf klicken Anwenden um die Änderungen zu speichern.
    Aktivierung der fehlenden TLS-Technologien
  5. Wenn Sie es geschafft haben, die Änderungen zu speichern, kehren Sie zum Notizblock++ und versuchen Sie erneut, die Plugins zu installieren, um zu sehen, ob das Problem jetzt behoben ist.

Falls das gleiche Problem weiterhin auftritt, fahren Sie mit der nächsten möglichen Fehlerbehebung unten fort.

Methode 4: Installieren Sie die neueste Version von Notepad++

Laut einigen betroffenen Benutzern können Sie auch erwarten, dass dieser Fehlercode in Situationen auftritt, in denen Sie tatsächlich versuchen, eine ältere Version von Notepad ++ zu verwenden, die nicht vollständig mit den neuesten Sicherheitsupdates unter Windows 10 kompatibel ist.

Mehrere betroffene Benutzer, die zuvor mit der gleichen Art von Problemen zu tun hatten, haben gemeldet, dass sie es geschafft haben, das Problem zu beheben „Installationsfehler: Die Installation von Compare ist fehlgeschlagen.“ indem Sie die aktuelle Notepad++-Version deinstallieren und alle verbleibenden Dateien entfernen, bevor Sie die neueste verfügbare Version, die mit Windows 10 kompatibel ist, erneut installieren:

  1. Drücken Sie Windows-Taste + R sich öffnen Lauf Dialogbox. Geben Sie als Nächstes ein ‘appwiz.cpl’ in das Textfeld und drücken Sie Eingeben die öffnen Programme und Funktionen Speisekarte. Wenn Sie vom . dazu aufgefordert werden UAC (Benutzerkontensteuerung), klicken Ja Administratorzugriff zu gewähren.
    Zugriff auf das Menü Programme und Funktionen
  2. Sobald du in der bist Programm und Funktionen blättern Sie nach unten durch die Liste der installierten Anwendungen und suchen Sie den zugehörigen Eintrag Notizblock++. Klicken Sie im gerade erschienenen Kontextmenü auf Deinstallieren aus dem gerade erschienenen Kontextmenü.
    Deinstallieren Sie die aktuelle Notepad++-Installation
  3. Öffnen Sie als Nächstes den Datei-Explorer und navigieren Sie zum folgenden Speicherort und entfernen Sie alle Restdateien, die von der alten Installation von installation übrig geblieben sind Notizblock++ bevor Sie Ihren Computer neu starten:
    C:Program FilesNotepad++
  4. Nachdem der Neustart des Computers abgeschlossen ist, öffnen Sie Ihren Standardbrowser, besuchen Sie die Download-Seite von Notepad++ und klicke auf Herunterladen Schaltfläche, die mit der neuesten Version von Notepad++ verknüpft ist.
    Laden Sie die neueste Version von Notepad++ herunter
  5. Sobald die ausführbare Installationsdatei erfolgreich heruntergeladen wurde, klicken Sie mit der rechten Maustaste darauf und wählen Sie Als Administrator ausführen aus dem gerade erschienenen Kontextmenü.
  6. Befolgen Sie im Installationsbildschirm die Anweisungen auf dem Bildschirm, um die Installation abzuschließen, bevor Sie Ihren Computer endgültig neu starten.
  7. Starten Sie nach Abschluss des nächsten Startvorgangs die kürzlich installierte Version von Notizblock++ und sehen, ob das Problem endlich behoben ist.

Wenn dieses Problem immer noch nicht behoben ist, fahren Sie mit dem letzten Fix unten fort.

Methode 5: Manuelles Installieren des Notepad++-Plugins

Wenn keine der oben genannten Methoden in Ihrem Fall funktioniert hat, können Sie auch versuchen, das fehlerhafte Plugin manuell zu installieren, es an der richtigen Stelle einzufügen und dann in die Hauptanwendung Notepad ++ zu importieren.

Diese Methode wurde von vielen Benutzern, denen wir begegnen, als effektiv bestätigt „Installationsfehler: Die Installation von Compare ist fehlgeschlagen.“ beim Versuch, ein älteres Plugin zu installieren.

Wenn dieses Szenario zutrifft, befolgen Sie die nachstehenden Anweisungen, um die aktualisierte Liste der Notepad++-Plugins manuell von Sourceforge herunterzuladen und dann das fehlerhafte Plugin in Notepad++ zu laden:

  1. Stellen Sie sicher, dass Notepad++ vollständig geschlossen ist und nicht im Hintergrund ausgeführt wird.
  2. Besuche den Downloadseite von Notepad++ Plugins von Ihrem bevorzugten Browser aus und klicken Sie auf Herunterladen um mit der Installation der Plugins zu beginnen.
    Notepad++-Plugins herunterladen
  3. Sobald der Download abgeschlossen ist, extrahieren Sie den Inhalt des gerade heruntergeladenen Archivs an den folgenden Speicherort:
    C:Program FilesNotepad++plugins
  4. Öffnen Sie als Nächstes Notepad ++ und klicken Sie auf die Einstellungen Eintrag aus der Multifunktionsleiste oben. Klicken Sie anschließend im gerade erschienenen Kontextmenü auf Importieren > Plugins importieren, Wählen Sie dann aus der Liste der Plugins die aus, die Sie seitlich laden möchten.
    Importieren der Plugins
  5. Als nächstes sollte Notepad ++ die Neustartmeldung anzeigen – Wenn Sie sie sehen, starten Sie sie wie angewiesen neu, dann sollte das neue Plugin in der Anwendung angezeigt werden.

Similar Posts

Leave a Reply

Your email address will not be published.